同花顺 便宜线,济装置线 源码

  目的说皓及代码

  //#@Fname=便宜线

  //#@comment=炒股神物器3-(济装置线)炒股神物器第3季强大势退场

  //#@control=

  //#@FuncType=

  //#@style=济装置线:Line2,成提交标价,3,0,1,5,16711935;J:Line2,成提交标价,3,0,1,5,16776960;A:Line2,成提交标价,2,0,1,5,65535;X:Line2,成提交标价,2,0,1,5,65280;MA3:Line2,成提交标价,1,0,1,5,16777215;MA2:Line2,成提交标价,2,0,1,5,255;

  //#@availperiod=2147430400

  //#@param=N=30.0000000001,2.0000000004,100.0000000004,1;

  //#@isDrawCurve=1

  //#@Fdesc=便宜线

  //#@defaultperiod=16384

  //#@coord=M

  //#@ordinate=0,0.000000;0,0.000000;0,0.000000;0,0.000000;0,0.000000;0;0,0.000000

  //#@@FUNCSPEC@=source

  AA:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,N))/MA(CLOSE,N);

  济装置线:DMA((2*CLOSE+LOW+HIGH)/4,AA),LINETHICK3,colormagenta;

  CC:=(CLOSE/济装置线);

  MA1:=MA(CC*(2*CLOSE+HIGH+LOW)/4,3);

  MAAA:=((MA1-济装置线)/济装置线)/3;

  TMP:=MA1-MAAA*MA1;

  J:IF(TMP<=济装置线,济装置线,DRAWNULL),LINETHICK3,colorcyan;

  A:TMP,LINETHICK2,coloryellow;

  X:IF(TMP<=济装置线,TMP,DRAWNULL),LINETHICK2,colorgreen;

  MA3:MA(C,42),colorwhite;

  MA2:MA(C,78),colorred;